Практика использования Бизнес-процессов и Задач в «1С:Предприятии 8.3»

В этой статье мы рассмотрим объекты «Бизнес-процессы» и «Задачи».

С одной стороны, подзадача по реализации бизнес-процессов является обязательной на Аттестации 1С:Специалист по платформе.

С другой стороны, во многих типовых решениях бизнес-процессы используются редко. Хотя фактически бизнес-процессов в конфигурациях автоматизировано множество, а сами эти объекты появились аж в 2004 году (с момента выхода «1С:Предприятие 8.0»).

Поэтому, чтобы понимать работу механизмов «Бизнес-процессов» и «Задач», недостаточно просто «подсмотреть в типовой». Возможности данных объектов нужно именно изучать.

Этим мы и займемся в данной статье. Плюс, дадим общие рекомендации по применению данного механизма в решении реальных задач.

Что такое бизнес-процессы в 1С

Безотносительно 1С бизнес-процесс – это совокупность взаимосвязанных действий, направленных на создание продукта или услуги для потребителей.

Примеры бизнес-процессов: производство вентиляторов, допродажа товаров клиента, подбор сотрудников и так далее. Причем часто бизнес-процессы можно детализировать. Например, в производстве продукции можно выделить такие бизнес-процессы, как закупка материалов, передача материалов в производство, движение материалов в производстве, выпуск продукции.

Для наглядной автоматизации бизнес-процессов в платформе «1С:Предприятие 8» существует объект «Бизнес-процесс». Он позволяет выстроить цепочку действий разных пользователей программы, которая приведет к определенному результату. Таким результатом может быть формирование отчетности, утверждение документа, заполнение карточки контрагента.

Объект «Бизнес-процесс» имеет графическое отображение, называемое картой маршрута. Это не что иное, как блок-схема, составленная из «кирпичиков»:

Элемент схемыГрафическое представлениеОписание
Точка стартаНачало бизнес-процесса, является обязательным
СтрелкаПоказывает последовательность переходов между точками
Точка действияСоответствует конкретному действию конкретного пользователя (или одного из пользователей с определенной ролью) в программе.
Точка условияОтвечает за проверку выполнения определенного условия, у которого может быть только 2 состояния: “Выполнено” или “Не выполнено”
Точка выбора вариантаДает возможность выбрать дальнейшие действия исходя из проверки условия, у которого может быть более двух состояний (аналог – Если-ИначеЕсли-…)
Точка разделенияСоответствует моменту, начиная с которого разные пользователи должны выполнять разные действия параллельно и независимо друг от друга
Точка слиянияСоответствует моменту, начиная с которого параллельные процессы вновь объединяются в один
Точка обработкиОтвечает за выполнение определенного алгоритма системой
Точка вложенного бизнес-процессаСоответствует выполнению другого бизнес-процесса, который является составной частью текущего
Таблица 1

Как видим, бизнес-процессы в системе могут иметь ветвления, параллельное выполнение, любое количество уровней вложенности.

Вот пример бизнес-процесса «Закрытие месяца» из 1С:УПП, где встречаются практически все возможные элементы:

Рисунок 1

Продвижение по карте маршрута невозможно реализовать без вспомогательного объекта «Задача» – «двигателя» бизнес-процесса. В каждой точке действия создается одна или несколько задач, и когда все задачи текущей точки завершены, происходит переход к следующей точке карты маршрута.

Использование объектов «Бизнес-процесс» для пользователя похоже на работу с документами:

  • Разные бизнес-процессы соответствуют различным действиям в системе (продажа товара, закрытие месяца, согласование заказа, …). То есть объект «Бизнес-процесс» в конфигурации определяет вид операции.
  • При старте пользователем нового бизнес-процесса создается несколько экземпляров, например – продажа вентиляторов контрагенту А, продажа холодильников контрагенту Б и так далее. То есть пользователь создает любое количество объектов информационной базы для каждого бизнес-процесса.

Практический пример

Рассмотрим практический пример. Необходимо автоматизировать процесс приема сотрудника на работу из 3 последовательных этапов:

  1. Младший кадровик заполняет личные данные сотрудника.
  2. Старший кадровик оформляет приказ о приеме сотрудника в статусе «Проект».
  3. Расчетчик проводит приказ о приеме в статусе «Утвержден».

Каждый этап бизнес-процесса выполняет отдельный пользователь с нужными правами доступа.

Требуется отслеживать ход приема новых сотрудников, каждый пользователь должен видеть свои задачи.

В реальных задачах также нужно учитывать права доступа. Так, в описанной задаче за утверждение документов «Прием на работу» отвечает расчетчик. А при проведении документа в статусе «Утвержден» формируются движения по регистру сведений «Плановые начисления». То есть расчетчик должен иметь право записи в этот регистр.

Бизнес-процесс будем реализовывать в конфигурации, где уже имеются необходимые документы и справочники:

Рисунок 2

Выгрузку базы с этой конфигурацией можно скачать по ссылке в конце статьи.

Начнем с создания нового бизнес-процесса:

Рисунок 3

В пользовательском режиме новый бизнес-процесс будет создаваться каждый раз при приеме нового сотрудника.

Изобразим карту маршрута бизнес-процесса для поставленной задачи:

Рисунок 4

Рисунок 5

Привязку к исполнителям мы настроим позднее.

В точке условия нужно определить, работал ли принимаемый сотрудник в нашей организации ранее. Если это так, то в базе уже заведен нужный элемент справочника «Физические лица» и заполнены личные данные. Добавим в бизнес-процесс реквизит (тип Булево), который позже обработаем в точке условия (то есть считаем, что пользователь сам определяет при приеме – новый это сотрудник или нет):

Рисунок 6

Теперь, когда у нас есть схема бизнес-процесса, необходимо организовать последовательность действий и распределение этих действий по ответственным лицам.

Объект конфигурации «Задача»

За действие пользователя в каждой точке бизнес-процесса отвечает специальный объект «Задача». Он является вспомогательным объектом, но именно с его помощью выстраивается цепочка действий пользователей: в каждой точке действия карты маршрута создаются задачи для одного или нескольких пользователей. Пока текущий пользователь не завершил свою задачу (то есть не установил стандартный реквизит «Выполнена» в значение «Истина»), задачи следующей точки маршрута для других пользователей созданы не будут.

То есть именно при выполнении задач происходит движение бизнес-процесса по карте маршрута.

Для наглядности рассмотрим, как выглядит список задач в демонстрационной базе конфигурации «Документооборот 8 ПРОФ, редакция 2.1». При запуске программы от имени пользователя Федоров О.П. (директор) на начальной странице открывается список всех невыполненных задач пользователя:

Рисунок 7

Вернемся к нашей конфигурации, создадим новый объект:

Рисунок 8
Отметим, что объект «Задача» может использоваться отдельно от объекта «Бизнес-процесс», но никак не наоборот. Используемая задача указывается в настройках бизнес-процесса в конфигураторе, и будет автоматически создаваться в пользовательском режиме при переходе на следующую точку маршрута.

Свяжем бизнес-процесс с задачей:

Рисунок 9
Обратите внимание! Несмотря на то, что в разных точках бизнес-процесса могут создаваться и редактироваться различные объекты системы, тип создаваемых задач на каждом из этапов будет одинаковым. Например, для решаемой задачи будут создаваться элементы справочников “Физические лица” и “Сотрудники”, а также документы “Прием на работу”. При этом в каждой точке бизнес-процесса будут создаваться задачи “Задача исполнителя”.

Более того, в типовых решениях 1С («Документооборот», «Управление торговлей, ред. 11») в разных бизнес-процессах используется один и тот же тип задач, чаще всего он называется «Задача исполнителя». Это делается для того, чтобы пользователь мог видеть общий список своих задач, относящихся к разным видам бизнес-процессов, как в примере выше из «Документооборота».

Адресация задач

Объект «Задача» предоставляет возможность использования вспомогательного регистра сведений, который обеспечивает распределение задач по исполнителям. Этот регистр называется регистром адресации.

Измерениями регистра адресации должны выступать те значения, по которым возможно однозначно определить исполнителя задачи. При этом в качестве одного из измерений чаще всего используется справочник «Пользователи», так как с помощью него удобно связать текущего пользователя программы с его задачами.

Однако использование справочника «Пользователи» как единственного измерения адресации на практике неудобно: например, конкретный пользователь может заболеть или сменить место работы, тогда придется перенастраивать адресацию задач. Таким образом, задачи удобнее привязывать не напрямую к пользователю, а к набору ролей, и одного измерения адресации чаще всего недостаточно.

Поэтому для нашего примера создадим в регистре адресации 2 измерения:

Рисунок 10

Здесь используется справочник «Роли исполнителей», который имеет следующие предопределенные элементы:

Рисунок 11

Создадим у задачи реквизиты адресации тех же типов, что и измерения регистра сведений:

Рисунок 12

Укажем для задачи регистр адресации. Для реквизитов адресации задачи настроим соответствие измерениям выбранного регистра сведений:

Рисунок 13

Теперь в карте маршрута бизнес-процесса доступна настройка адресации. Укажем для каждой точки действия нужную роль исполнителя:

Рисунок 14

Чтобы обеспечить ветвление в точке условия, требуется обработчик проверки условия – функция в модуле объекта бизнес-процесса, которая возвращает значение Ложь или Истина. Создадим такой обработчик для точки маршрута ПовторныйПрием:

Рисунок 15

Процедура ПовторныйПриемПроверкаУсловия(ТочкаМаршрутаБизнесПроцесса, Результат) Результат = Не ЭтоПервичныйПрием; КонецПроцедуры

Чтобы знать, от имени какого пользователя запущен текущий сеанс, нам потребуется параметр сеанса. Создадим его:

Рисунок 16

Укажем, что созданный параметр сеанса будет хранить текущего исполнителя задач, а также укажем основной реквизит адресации для задачи:

Рисунок 17

Сделаем так, чтобы при запуске «1С:Предприятия» в параметр сеанса ТекущийПользователь подбиралось нужное значение из справочника «Пользователи». Соответствие будем устанавливать по имени, и если элемент справочника «Пользователи» с нужным именем не найден, то создадим его. Код функции УстановкаПараметровСеанса() в модуле сеанса:


Процедура УстановкаПараметровСеанса(ТребуемыеПараметры) ИмяПольз = ИмяПользователя(); ТекПользователь = Справочники.Пользователи.НайтиПоНаименованию(ИмяПольз, Истина); Если Не ЗначениеЗаполнено(ТекПользователь) Тогда НовыйПользователь = Справочники.Пользователи.СоздатьЭлемент(); НовыйПользователь.Наименование = ИмяПольз; НовыйПользователь.Код = ИмяПольз; НовыйПользователь.Записать(); ТекПользователь = НовыйПользователь.Ссылка; КонецЕсли; ПараметрыСеанса.ТекущийПользователь = ТекПользователь; КонецПроцедуры

После того, как все нужные элементы справочника «Пользователи» будут созданы, заполним регистр адресации в режиме «1С:Предприятие»:

Рисунок 18
Обратите внимание! Настройка адресации бизнес-процесса с использованием справочника (в нашем случае это справочник «Роли исполнителей») подразумевает использование предопределенных элементов этого справочника, только они доступны для выбора в точке действия бизнес-процесса.

Отображение задач по исполнителям

Теперь поработаем над формой списка задач. Конечно, пользователю хотелось бы, чтобы по умолчанию в списке задач отображались только его задачи. Для этого создадим форму списка задачи «Задача исполнителя» и в настройках основного реквизита Список поменяем основную таблицу на Задача.ЗадачаИсполнителя.ЗадачиПоИсполнителю:

Рисунок 19

Также можно оставить только еще не выполненные задачи, добавив в настройку списка соответствующий отбор:

Рисунок 20

Теперь уже можно попробовать создать экземпляр бизнес-процесса, задачи будут создаваться у нужных пользователей. Для этого под любым пользователем, имеющим права на запись бизнес-процесса «Прием нового сотрудника» (например, под Ивановой А.И.), из раздела «Кадровый учет → Прием нового сотрудника» создаем новый экземпляр бизнес-процесса и стартуем его:

Рисунок 21

Рисунок 22

После этого у пользователя Петрова В.П. в списке задач (Кадровый учет → Задача исполнителя) появится новая задача:

Рисунок 23

Визуализация хода бизнес-процесса

Пока функциональность нашей разработки почти на нуле – только формируются задачи и пользователи вручную отмечают их исполнение.

Для начала хотелось бы иметь возможность отслеживать состояние бизнес-процесса, то есть в какой точке он сейчас находится. Для этого создадим форму бизнес-процесса и добавим на нее реквизит КартаБП типа ГрафическаяСхема, а также выведем элемент управления на форму:

Рисунок 24

Затем в модуле формы бизнес-процесса создадим процедуру ОбновитьКартуМаршрута:


&НаСервере Процедура ОбновитьКартуМаршрута() ОбъектБП = РеквизитФормыВЗначение("Объект"); КартаБП = ОбъектБП.ПолучитьКартуМаршрута(); КонецПроцедуры

Вызовем эту процедуру в обработчике события ПриЧтенииНаСервере формы бизнес-процесса:


&НаСервере Процедура ПриЧтенииНаСервере(ТекущийОбъект) ОбновитьКартуМаршрута(); КонецПроцедуры

После этого при открытии формы бизнес-процесса на карте маршрута будет отмечаться текущее положение:

Рисунок 25
Мы используем обработчик ПриЧтенииНаСервере, т.к. он вызывается самым первым в процессе открытия управляемой формы объекта и выполняется только для уже записанных объектов.

Использовать обработчик ПриСозданииНаСервере для выполнения кода также допустимо, но данный обработчик вызывается и для тех объектов, которые еще не записаны. В нашем случае это приведет к выполнению лишних действий, ведь вновь создаваемый бизнес-процесс еще не стартован, а значит, он всегда находится в своей начальной точке.

Сделаем так, чтобы при нажатии кнопки «Старт» на форме бизнес-процесса карта маршрута обновлялась. Для этого вызовем ту же процедуру ОбновитьКартуМаршрута в обработчике ПослеЗаписиНаСервере:


&НаСервере Процедура ПослеЗаписиНаСервере(ТекущийОбъект, ПараметрыЗаписи) ОбновитьКартуМаршрута(); КонецПроцедуры

В таком виде задача может считаться решенной в рамках подготовки к экзамену «1С:Специалист» по платформе. Но мы пойдем немного дальше.

События задач и точек действия бизнес-процессов

Для начала добавим автоматическую запись исполнителя в задачу при ее выполнении, чтобы в будущем можно было отследить, кем именно она была выполнена. Ведь младших кадровиков может быть несколько – баба Нюра и баба Катя. До момента выполнения задачи она будет отображаться в списках всех потенциальных исполнителей.

Итак, добавим в модуль объекта ЗадачаИсполнителя стандартный обработчик ПередВыполнением со следующим кодом:


Процедура ПередВыполнением(Отказ) Исполнитель = ПараметрыСеанса.ТекущийПользователь; КонецПроцедуры

Теперь добавим в бизнес-процесс реквизиты, которые позволят хранить информацию о выполняемых действиях:

Рисунок 26

Поработаем и с задачей. Выведем на форму задачи ссылку на родительский бизнес-процесс и его реквизиты:

Рисунок 27

В наименовании задачи было бы неплохо видеть не только название точки маршрута, но и ФИО человека, которого требуется принять на работу. Для этого в модуле объекта бизнес-процесса определим процедуру УстановитьНаименованиеЗадачи, и будем вызывать ее при создании задач:


Процедура УстановитьНаименованиеЗадачи(ТочкаМаршрутаБизнесПроцесса, Задача) Задача.Наименование = ТочкаМаршрутаБизнесПроцесса.НаименованиеЗадачи + " " + СокрЛП(ФизЛицо.Наименование); КонецПроцедуры Процедура ОбщаяПриСозданииЗадач(ТочкаМаршрутаБизнесПроцесса, ФормируемыеЗадачи, Отказ) Для каждого НоваяЗадача Из ФормируемыеЗадачи Цикл УстановитьНаименованиеЗадачи(ТочкаМаршрутаБизнесПроцесса, НоваяЗадача); КонецЦикла; КонецПроцедуры

Процедуру ОбщаяПриСозданииЗадач привяжем к каждой точке маршрута бизнес-процесса. Это можно сделать через карту маршрута:

Рисунок 28

На каждой точке маршрута можно задавать отдельные обработчики событий, если требуется выполнять различные действия.
На этапе выполнения задачи добавим контроль над пользователем со стороны системы: не будем позволять отмечать задачу как выполненную, если необходимые данные не внесены. Для этого в модуль объекта бизнес-процесса добавим функцию ПроверитьВыполнениеЗадачи, которую будем вызывать в обработчике ОбщаяПередВыполнением в каждой точке маршрута (привязка осуществляется также через карту маршрута):


Функция ПроверитьВыполнениеЗадачи(ТочкаМаршрутаБизнесПроцесса, Задача) БП = Задача.БизнесПроцесс; Результат = Ложь; Если ТочкаМаршрутаБизнесПроцесса = БизнесПроцессы.ПриемНовогоСотрудника.ТочкиМаршрута.ВводПервичныхДанныхФизлица Тогда Если ЗначениеЗаполнено(БП.ФизЛицо) И ЗначениеЗаполнено(БП.Сотрудник) Тогда Результат = ЗначениеЗаполнено(БП.ФизЛицо.ДатаРождения) И ЗначениеЗаполнено(БП.ФизЛицо.Пол); КонецЕсли; ИначеЕсли ТочкаМаршрутаБизнесПроцесса = БизнесПроцессы.ПриемНовогоСотрудника.ТочкиМаршрута.ВводПриемаНаРаботу Тогда Результат = ЗначениеЗаполнено(БП.ПриемНаРаботу); ИначеЕсли ТочкаМаршрутаБизнесПроцесса = БизнесПроцессы.ПриемНовогоСотрудника.ТочкиМаршрута.УтверждениеПриемаНаРаботу Тогда ДокПрием = БП.ПриемНаРаботу; Результат = ЗначениеЗаполнено(ДокПрием.Оклад) И ДокПрием.Статус = Перечисления.СтатусыДокументов.Утвержден; КонецЕсли; Возврат Результат; КонецФункции Процедура ОбщаяПередВыполнением(ТочкаМаршрутаБизнесПроцесса, Задача, Отказ) Если Не ПроверитьВыполнениеЗадачи(ТочкаМаршрутаБизнесПроцесса, Задача) Тогда Сообщить("Не выполнены действия, необходимые для выполнения задачи!", СтатусСообщения.Важное); Отказ = Истина; КонецЕсли; КонецПроцедуры

Готово, можно тестировать!

Подведем итоги

Мы описали только базовые приемы работы с бизнес-процессами и задачами в 1С:Предприятии 8.3. Как минимум, требуется добавить еще множество проверок введенных данных и «красивостей» на уровне форм.

Но цель статьи – показать, как можно использовать объекты системы при автоматизации бизнес-процессов.

Выгрузку базы готового примера можно скачать в конце статьи и использовать в качестве шаблона.

Есть еще множество нюансов, которые просто невозможно рассмотреть в одной статье: программное создание и выполнение задач, групповые задачи, использование вложенных бизнес-процессов, настройка ролей и прав доступа. Плюс зачастую вместо «унылой» формы задачи вызывается форма определенного объекта конфигурации – документа или справочника.

Если эти темы Вам интересны, оставляйте комментарии – и мы продолжим освещать тему бизнес-процессов. :)

Об авторе

Автор статьи – Алина Баринова

Консультант-разработчик, компания “Infosuite” (г. Москва)

E-mail: barinovaaa@yandex.ru
Facebook: www.facebook.com/barinovaaa

Выгрузки ИБ и PDF-версия статьи для участников группы ВКонтакте

Мы ведем группу ВКонтакте – http://vk.com/kursypo1c.

Если Вы еще не вступили в нее – сделайте это сейчас, и в блоке ниже (на этой странице) появятся ссылки на скачивание материалов.


Статья в PDF-форматеСтатья в PDF-формате
Вы можете скачать эту статью в формате PDF по ссылке:
Ссылка доступна для зарегистрированных пользователей)
Ссылка доступна для зарегистрированных пользователей)
Ссылка доступна для зарегистрированных пользователей)


67 комментариев к “Практика использования Бизнес-процессов и Задач в «1С:Предприятии 8.3»

  1. rmarkovych сказал:

    Здравствуйте!
    Необходима консультация. (УТ11+CRM) Создаю БП, в котором по Заказу Клиента необходимо создать несколько Заказов Поставщику (в зависимости от Поставщика товаров). Точное количество Партнеров – изначально не известно. Допустим, обработкой Партнеров и, соответственно, товар я определю. Но каким образом, после выполнения задачи по созданию Заказа Клиента, мне создать несколько Заказов Поставщику? Даже если я Весь процесс Закупки товара перенесу во Вложенный БП, то как мне создать несколько таких вложенных БП.
    Буду признателен за помощь.

    • Кузьмин Сергей сказал:

      Мы не оказываем консультационных услуг.
      Описанная Вами задача сложная и требует детального анализа.
      Участников курсов много и если мы будем одному (или нескольким) помогать в решении проблем на проектах, то на вопросы остальных участников по курсам просто не останется времени.
      Просьба отнестись с пониманием.

  2. rmarkovych сказал:

    Здравствуйте, Алина!
    Скажите пожалуйста, есть ли у Вас курсы по этой теме, или еще какая-то дополнительная литература? Только начинаю работу с БП. Готов купить.
    С уважением, Ростислав

    • Кузьмин Сергей сказал:

      Нет такого курса. Это просто отдельная статья отдельного автора.
      Подробно бизнес-процессы не рассматриваются.

  3. Cos сказал:

    Здравствуйте! Давно вхожу в вашу группу в Вконтакте, но ссылка на скачивание статьи в PDF – не появляется. В чем может быть дело?
    Браузеры – Chrome и MS Edge. Результат – одинаков. :(

    • Кузьмин Сергей сказал:

      Нужно нажать на кнопку Подписаться и войти в Ваш профиль ВКонтакте, после этого появится ссылка на материалы.
      Если проблема сохранится, пришлите скриншот ошибки на почту службы поддержки Support@NasF.ru.

  4. Cos сказал:

    Здравствуйте!
    Большое спасибо за статью!
    Скажите пожалуйста, а есть ли продолжение?
    В частности, интересует вопрос программного создания, выполнения и завершения бизнес-процесса.

    • Евгений Гилев (Мастер-тренер) сказал:

      Нет, продолжения в виде статьи не планируется :)

  5. Necropunk сказал:

    Вконтакте зашел, на сайте авторизован, в группt состою, все адблоки и прокси отключены, но где должна быть ссылка пишет: Невозможно загрузить SDK сценарий для vk. Пожалуйста, убедитесь, что ничто не препятствует загрузке социальных сценариев в вашем браузере. Некоторые расширения браузера (Avast, PrivDog, AdBlock и т.д.) могут вызывать эту проблему. Отключите их и попробуйте снова.
    :(

    А за статью спасибо, мало все-таки инфы про бизнес-процессы, приходилось самому ковырять.

    • Юлия Толстых сказал:

      Добрый день! Рады, что статья оказалась Вам полезна!
      Попробуйте очистить кэш или воспользоваться другим браузером. Если проблема не будет решена, сообщите об этом в письме на support@kursy-po-1C.ru

  6. leokor сказал:

    Статья очень хорошая.К сожалению инструмент задач и бизнес процессов 1С не позволяет реально описывать бизнес процессы предприятия как это реализовано в ARIS или специализированных инструментах (например, Business Studio). Здесь приведена реализация конкретного бизнес процесса, используя объекты 1С и обработчики в точках маршрута, что очень ценно для понимания, как эти “аппендиксы” (задачи и бизнес процессы 1С) все таки можно использовать в практической работе.

    • gangir сказал:

      “К сожалению инструмент задач и бизнес процессов 1С не позволяет реально описывать бизнес процессы предприятия Источник: ©Курсы-по-1С.рф”….
      Скорее Заратустра не позволяет.
      Все прекрасно описывается,только стандартную обработку отключать приходится

  7. Андрей сказал:

    Для начального ввода в курс дела – отлично! Присоединяюсь к желающим продолжения

    • Татьяна Гужавина сказал:

      Нажмите “Подписаться” и авторизуйтесь под Вашим профилем ВКонтакте. После этого PDF-версия статьи должна отобразиться для Вас внизу статьи.
      Попробуйте также очистить кэш и подписаться через другой браузер.

  8. Венер сказал:

    Спасибо! Но, при всём уважении к вашему труду: “закупка материалов” это не “бизнес-процесс”, это “процесс”. 1С ввела путаницу назвав объект бизнес-процессом.

    • barinovaaa сказал:

      Да, безусловно, закупка материалов – это не самостоятельный бизнес-процесс. Она может выступать только как часть бизнес-процесса

  9. Эдуард Соловьев сказал:

    Спасибо за статью, очень вовремя и хорошо преподнесено.

  10. Дмитрий сказал:

    Спасибо! Жаль, что я принципиально “в контакте” не регистрируюсь.

    • Andry сказал:

      я тоже не регистрируюсь, вернее я зарегистрировался, и не более того.

  11. Константин сказал:

    Есть такой вопрос, по моему по этой теме как раз:
    Занимаемся выпуском шкафов с эл.оборудованием.

    Например одна бригад ее день и процесс сборки шкафа.

    1 получила комплектующие (Этап Комплектующие)
    2 собирает металлоконструкцию
    3 делает монтаж
    4 маркировщики оклеивают (бригада параллельно делает другой шкаф например)
    5 ОТК проверяет
    6 ЭТЛ проводит испытания
    7 и тут опять монтажники его упаковывают

    У бригады по 3-5 шкафов параллельно собирается, значит мы должны увидеть информацию в 1С какая бригада и какие сотрудники занимались этим шкафом.
    Все это нужно чтобы:

    1. Начальник производство мог видеть какой этап производства. Какие сотрудники могут начать на следующей неделе новые проекты.

    2. И видеть историю: Зав. номера, какая бригада, какие сотрудники, кто ОТК, Кто испытатель.

    Я работаю в системе ПЛАНфиксе, ведь удобно когда тебе напоминает про задачу, и от 1С хочу подобия. Чтобы сразу пришло сообщение что шкаф нужно начать испытывать, Маркировщики его промаркировали и т.д…

    Как это все реализовать в ERP? Кто-нибудь подскажет, что и где почитать по этой теме или курс какой пройти? Просто тыкая по встроенному функционалу и читая разные обрывки сведений в инете – до меня не доходит общее понимание поставленной задачи(

  12. Роман сказал:

    Эх, думал что то новое узнаю. Но за такой труд благодарю! От души. по сабжу:
    Статическая карта маршрута в наше время уже не актуально. Очень надеюсь что в 8.4 появится динамика. С нормальным редактором схемы маршрута. Сам работаю с EDI, множество всевозможных вариантов обработки, приходится изгаляться.
    Еще такой вопрос интересен, может кто что дельное подскажет, как правильно сделать асинхронный обработчик? Ну например, ожидание входящего сообщения.

    • Евгений Гилев (Мастер-тренер) сказал:

      Начнем с того, что 8.4 пока еще находится на линии горизонта, которая удаляется по мере нашего приближения :)

      Более того, пока доработку карты маршрута и вообще бизнес-процессов разработчики вообще не анонсируют.

      Сам работаю с EDI, множество всевозможных вариантов обработки, приходится изгаляться.

      Опишите чуть детальнее, думаю, что читателям будет интересно.

      • Роман сказал:

        Да не вопрос. Пожалуйста. EDI – это процесс обмена сообщениями между 2мя участниками – поставщик и торговая сеть. Процесс – последовательность таких сообщений, друг за другом, там отправка документа, либо его получение. Так вот, для каждой сети эта последовательность разная, а карту маршрута нужно сделать универсальную. Старт возможен как с входящего сообщения, так и с проведения документа, к тому же в обработчиках пользователь может пропустить какой либо шаг. 1-е сообщение стартует процесс, а вот следующие? с этим не очень получается. Не плодить же под каждую сеть свой БП со своей картой маршрутизации. А подменить по условиям карту нельзя. Если что детальнее – спрашивайте))

        • Николай Зайков сказал:

          Согласен полностью, приходится добавлять ветвления в маршрут и это может сильно усложнить его.

    • Татьяна Гужавина сказал:

      Денис, нажмите “Подписаться” и авторизуйтесь под Вашим профилем ВКонтакте. После этого PDF-версия статьи отобразится для Вас на странице со статьей.

  13. kudla сказал:

    Спасибо! Очень полезная статья. А для меня сейчас как раз – крайне своевременная :). Очень хотелось бы увидеть продолжение. Перечисленные в итогах нюансы – это как раз то, что позволит научиться создавать решения, действительно удобные в использовании.

  14. accountit сказал:

    Не менее интересной была бы статья о том, как настроить бизнес процессы без конфигурирования и добавление объектов Бизнес процесс. Т.е о том как можно настроить для этих задач 1с докуметооборот и 1с управление холдингом.

    • Всеволод сказал:

      УХ и ДО тяжеловатые конфигурации для массовых курсов.
      Простые БП интересно настраиваются в ОптимаСофт, но конфигурация не очень популярная.

  15. Victor031 сказал:

    Доброго времени суток! Дошел до момента, когда нужно в форме списка задачи исполнителю поменять основную таблицу в реквизите “список”, который имеет тип “динамический список”, но почему то у меня доступна только таблица “Задача Исполнителя”, подскажите, в чем ошибся?

    • Насипов Фарит сказал:

      Кто будет? И что они будут с Международным БухУчетом?
      Вы про мировое правительство? Рептилоидов? :)

  16. Ярослав сказал:

    Спасибо достаточно просто и понятно раскрыты основные моменты

  17. h_slava сказал:

    Все хорошо, но почему бы не дать возможность скачивать с этого сайта, зачему нужен “в контакте” и т.п. чем данный сайт хуже, как по мне так тут самое место !

    • Татьяна Гужавина сказал:

      Скатать PDF-версию статью можно именно с нашего сайта, но только участникам группы ВКонтакте.

  18. labamba сказал:

    Статья отличная.
    Но мне кажется, что нужно сделать еще одну, где были бы примеры адаптации подсистемы Бизнес-Процессов из БСП

  19. zigan2005 сказал:

    Спасибо за статью! Очень интересно, кратко и самое главное доступно и без воды! )

  20. Елена сказал:

    Статья полезная и интересная! Спасибо большое! В следующий статьях хотелось бы увидеть развитие в сторону открытия определенного объекта конфигурации, а не формы задачи.

  21. Дмитрий сказал:

    Спасибо! Положил в избранное. Жду продолжения!
    Иногда полезно освежить знания которые редко используются.

  22. Valery_Izh сказал:

    Спасибо за статью. Алина, у меня вопрос: возможна ли полноценная работа с бизнес-процессами при помощи программного кода?
    То есть: хотелось бы создавать некую консоль конструирования бизнес-процессов в пользовательском режиме.
    При этом, была бы возможность:
    1. Использования не только предопределенных видов справочников, но и элементов созданных в режиме 1С предприятия.
    2. Без привлечения программиста 1С и без внесения правки в конфигурацию, добавлять новые бизнес-процессы.

    • Дмитрий сказал:

      У франча “ПервыйБит” есть собственная разработка(надстройка) которая позволяла делать что-то подобное.

    • barinovaaa сказал:

      Да, полноценная работа с бизнес-процессами при помощи программного кода возможна. Программное создание задач как раз и дает возможность использования не предопределенных элементов справочника. По поводу добавления новых бизнес-процессов, я предполагаю, что это возможно реализовать путем использования бизнес-процессов одного вида (т.е. в конфигураторе ничего не добавляя), но с настраиваемой картой маршрута. Что-то подобное, насколько мне известно, реализовано в «1С:CRM 2.0».

      • Александр сказал:

        Да, там можно создавать свои БП с собственными картами маршрута и вложенностью без использования конфигуратора: рисуете карту, далее настраиваете этапы БП, определяете автоматически создаваемые объекты, общие настройки самого БП ( к примеру, можно ли пропускать или досрочно завершать данный этап) и вуаля – все готово =)
        справедливо для 1С:CRM 2.0 и 3.0

    • Дмитрий сказал:

      “ИТИЛ ПРОФ” настройка маршрутов инцидентов, запросов на обслуживание. Подсистема Service Desk. Конфа от раруса.

    • Роман сказал:

      У ПитерСофт есть замечательная подсистема “Управление процессами”, там все четко, удобно, и без программиста. Но денег стоит прилично. Сам пытался подобное делать, но нет нормальных инструментов управления графической схемой. Да впринципе можно и это обойти если постаратся. Динамическая карта маршрута – вот это моя мечта))

  23. Прилуцкий Александр сказал:

    Добрый день! Я состою в группе, но не могу скачать пример.Подскажите, что не так?

    • Татьяна Гужавина сказал:

      Доброго дня, Александр!
      Необходимо нажать “Подписаться” и далее авторизоваться ВКонтакте, чтобы скрипт Вас узнал.

  24. Екатерина сказал:

    Статья полезная. Стоит развивать и дальше тему бизнес-процессов=)

  25. Сергей сказал:

    Спасибо за статью.

    Информация, по данной тематике будет ОЧЕНЬ полезной. Хотелось бы увидеть продолжение.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Мы используем файлы cookies, чтобы сделать сайт удобнее.
Продолжая просмотр сайта, Вы соглашаетесь с их использованием.
Подробнее